Getting Started With D-RATS
A Quick Start Guide

D-RATS is a free, easy to use, multi-platform program for data communications with D-STAR devices or
through the Internet. The software can be run on Windows, MacOS and Linux/UNIX computers. D-RATS
provides many functions including:

e |nstant messaging style chat

e Addressable messaging with attachments to other online stations, SMTP email addresses,
Winlink 2000 addresses

e Send forms (predefined forms included, define custom forms)

e Unattended file transfer (all file types)

e Position reporting with included maps

e Repeater proxy software links radio, Internet clients

Step 1 — Download and Install

Download the program at http://www.d-rats.com for your operating system and install to your
computer.

Step 2 — Set Preferences

Prior to using D-RATS there are a number of preferences that must be configured. These can be
accessed by selecting File > Preferences:

50 Wiew  Help

— Impork Message enk Log Stations
E Export Message & @ 'Tl
Reply Delete  Mark Read Mark Unread
0 Message Templates b« | subject 4 Type * Date 4

Ping Skation Ckrl+P

3
a

v Connected to Internet

Quit ChrlG

My Status
online w

Cnline (D-RATS)

A list of configurable item groups will appear in the left hand column. The following subsections describe
the options contained in each group.



r@ Config Iﬁw

=l Preferences Callsign WAL
Paths Mame John Do
GPS Sign-on Message Enabled | Online (D-RATS)
Appearance Sign-off Message Enabled | Going offline (D-RATS)
Chat Units Imperial |E|
Sounds Show time in UTC Enabled
Messages Ping reply
= Radio Language English |Z|
Transfers Blink tray on

Incoming Messages Enabled

= Metwork Mew Chat Messages Enabled
TCP Gateway Incoming Files Enabled
TCP Forwarding Received Events [C] Enabled
Outgeoing Email
Ernail Accounts
Ernail Access
Save ] ’ Cancel

e Callsign: Normally, your FCC callsign is entered. Optionally, a tactical callsign may be used. The
callsign will identify the station for chat, messaging and file transfer. When sending to this
station the callsign entered above is used to address the station.

e Name: Enter your name or location (ex. EOC, Shelter 1)

For a quick start, leave all other information at its default value.

Step 3 — Set Paths

Under Paths, you may leave these at their default value or define a different folder. The important one
is the File Transfer Path. This folder is used in File Transfers as your local location for remote stations to
view and download your files. Files uploaded to your station are placed here.
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= Preferences File Transfer Path | C:\Program Files\D-RATS\Transfer

m Map Storage Path | C\Program Files\D-RATS\maps

GP3 Form Logo Path | C\Program Files\D-RATS\logos

I
2
fil
=

D0
E

==
z
m
=1

Appearance
Chat
Sounds
Messages

=l Radio
Transfers

= Metwork
TCP Gateway
TCP Forwarding
Outgoing Email
Email Accounts

Email Access

Save | | Cancel

Step 4 — Define Radios

In this section, you will define the connections D-RATS will use to communicate. If connecting to a D-
STAR radio, the GPS settings must be disabled in the menus of the radio. The table below provides the
information for most lcom radios needed to define a radio in this section and set the menu selections.

Radio Rate Radio settings required for D-RATS functions Updated 12/5/2014
9600
ID-51 Plus Note: Fast Data only works with another ID-51A Plus or ID-5100A with firmware update)
(Fast Data) GPS>GPS SET>GPS Select>OFF, GPS>GPS TX Mode = OFF, GPS>GPS Auto TX = OFF, GPS>GPS Set>GPS Out = OFF,
DV Set>DV Data TX = Auto, DV SET>DV Fast Data>Fast Data>ON, Function>CI-V>CI-V (Data Jack)>OFF
9600
ID-51 Plus GPS>GPS SET>GPS Select>OFF, GPS>GPS TX Mode = OFF, GPS>GPS Auto TX = OFF, GPS>GPS Set>GPS Out = OFF,
(Slow Data) DV Set>DV Data TX = Auto, DV SET>DV Fast Data>Fast Data>OFF, Function>CI-V>CI-V (Data Jack)>OFF
ID-31A/51A 9600
(standard GPS>GPS SET>GPS Select>0OFF, GPS>GPS TX Mode = OFF, GPS>GPS Auto TX = OFF, GPS>GPS Set>GPS Out = OFF,
. DV Set>DV Data TX = Auto,
Edition)
ID-5100A 9600 Using a Data Cable: Function>Data Speed=9600, DV Set>DV Data TX=Auto,
IC-7100A 9600 |ysing a USB Cable: GPS>GPS Select=OFF, GPS>GPS TX Mode=OFF, GPS>GPS Auto TX=OFF,
Connectors>USB2/DATA1Function>USB2 Function=DV Data, Connectors>USB2/Datal Function>GPS Out=OFF,
Connectors>USB2/Datal Function>DV Data/GPS Out Baud=9600
Using a Data Cable: GPS>GPS Select=OFF, GPS>GPS TX Mode=0FF, GPS>GPS Auto TX=OFF,
Connectors>USB2/DATA1Function>Datal Function=DV Data, Connectors>USB2/Datal Function>GPS Out=0FF,
Connectors>USB2/Datal Function>DV Data/GPS Out Baud=9600
IC-80AD 9600  |DATATX = AUTO, GPS-TX = OFF, GPS.ATX = OFF
1C-U82 9600 ATX = ATXON, SPD = SPD96
1C-v82 9600 ATX = ATXON, SPD = SPD96
IC-91AD 38400 DV DATA TX = AUTO, GPS TX = DISABLED, GPS AUTO TX = OFF
IC-92AD 38400  |pV DATA TX = AUTO, GPS TX = DISABLED, GPS AUTO TX = OFF
1C-2200 9600 ATX = ATXON, SPD = SPD96
1C-2820 9600 DV DATA TX = AUTO, GPS TX = DISABLED, GPS AUTO TX = OFF, UT123 must be installed
1D-800H 9600 DVT = DVTAT, SPD = SPD96
ID-880H 9600 DATATX = AUTO, GPS-TX = OFF, GPS.ATX = OFF
ID-1 19200  IDV DATA TX = AUTO, Cannot use PC application




To use D-RATS with a D-STAR radio, it must be defined in the Radio section of the Preferences as below.

K Config X

= Preferences Enabled * |Port 1 Settings 1 Sniff 4 |Raw Text 4 | MName 1

Paths netiref,d-rats.com: 2000 2600 ] RatFlector

GPS ComM2 9600 ] 1C-2820

Appearance ] COME 15200 ] ID-1

Chat

Sounds

Messages
Transfers
= Metwork

TCP Gateway

TCP Forwarding

Ciutgoing Email

Incoming Email

Email Access

Add Edit
I Save ] [ Cancel l

From the Config > Radio screen, click “Add” and @ e 2 ke - ﬁ
select Type as Serial if connection to the radio with Name |IC-92AD
a serial cable. This is the normal connection type for Type [Serial E
aradio. Select the Serial Port that your data cable A D-STAR radio connected to a serial port
connects to on the computer. If you are using a USB Parameters
to Serial adapter or a serial cable with a USB - - IEI
connection, you must locate the COM port number.
In Windows, select START, Control Panel, System Baud Rate | 38400 E

and Device Manager. Under Ports, you will see the
COM Port assigned. The Baud Rate is dependent on
the radio settings. The default baud rate is shown in
the table above for each radio. You may add a Name

to add a unique name to this radio. Click Add to

save the configuration. .

Add H e
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On the Config > Radio screen, ensure that the box is checked for the radio you have defined and wish to
use. You should only have one box checked at a time.




To connect to the Internet (without a D-STAR radio), [ @ Add a port ﬁ’
you will define and use a Repeater Proxy also known

as a Ratflector. These are used to connect D-RATS Mame |RAT

Internet users together and may also connect to a D- Type |Metwork |E|
STAR radio to link RF users as well. The Ratflector A network link to a ratflector instance

you use is determined by the D-RATS Administrators Parameters

in your area. A default Ratflector is usually defined in Host Address | ref.d-rats.com

D-RATS, but you may configure one just as you Port 9000 =

configure a radio.
Password

From the Config > Radio screen, click Add and select
Network. Under Host, add the address of the
Ratflector you intend to use. “ref.d-rats.com” is a

public ratflector available for general use by Internet
Add || Cancel

users and generally has activity anytime. Port 9000 is
the default port used by most all ratflectors. —
ref.d-rats.com is a public ratflector.

Click Add to save your configuration. On the Config > Radio screen, ensure that the box is checked for
the radio you have defined and wish to use.

Step 5 — Transfers

This section defines the parameters used for communicating between D-RATS stations. Under Block
Size, the larger the value, the more efficient the transfer is on a good connection. On a bad connection,
setting this to be smaller reduces the amount of data that must be re-sent in the event of a bit of
corruption. Normally, the default value of 512 is good. Normally the default values for the other settings
are good for most situations. Make sure the “Remote file transfers” box is checked.

re Config @1
(Bever]

= Preferences Block size 512 | Revert
Paths Pipeline blocks 4 =/ | Revert
GPS Remote file transfers  [¥] Enabled
Appearance Warmup Length g = | Revert
Chat Warmup timecut 3 : Revert
Sound =
oHnds Force transmission delay |0 <| | Revert
Messages .
Allow file deletes from
=l Radio .
Remote admin password
Transfers
=l Metwork
TCP Gateway
TCP Forwarding
Outgeing Email
Email Accounts
Email Access

Save J l Cancel




Step 6— Messages

This section defines how messages are handled in D-RATS. The settings below are suggested. For the

“My Winlink SSID” setting, any valid SSID may be used.

r‘a Config ﬁ-‘
=l Preferences Automatically forward messages Enabled
Paths Queue flush interval 30 : seconds
GPS Station TTL 3600 - seconds
Appearance Include original in reply [] Enabled
Chat Allow POP3 Gateway Enabled
Sounds Allow WL2K Gateway Enabled
WL2K Connection Metwork Iz‘
= Radio WL2K Network Server serverwinlink.org B Port | 8772 =
Transfers WL2K RMS Station on port
= Network My Winlink SSID 9 |
TCP Gateway POP3 Server [] Enabled on port| 9110 :
TCP Forwarding SMTP Server [] Enabled on port| 9025
Outgoing Email
Email Accounts
Ernail Access
Save I l Cancel

NOW LET’S USE D-RATS

Upon opening D-RATS, you will see four tabs across the top of the screen (Messages, Chat, Files and
Event Log). Whenever there is activity in any of the modes, the program border will flash and the tab

with activity will turn blue.

Let’s start with Chat. Select the Chat tab. You may expand the screen size by grabbing a corner with
your mouse and dragging to the desired size. If you selected the public Ratflector (ref.d-rats.com) under
Radios, a list of online stations will appear on the righ side of the screen under Stations. If none appear,
with you mouse inside the t area, right-click and select Ping all Stations. You should see a list as stations
reply to your ping. You can chat with the online stations by typing your message in the area near the

bottom of the screen as shown below.
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Next, let’s send a message to another station. Click on the Messages tab at the top. The Messages tab
looks like many email clients with a familiar Inbox, Outbox, etc., and New, Forward, Reply, etc.

§¢ D-RATS: WB4QDX
File View Help
Message5| Chat | Files |E1.rer1t Log| Stations (2) |
T T— - S = 5 & : © WB4QDX (8m)
Mew: Forward Reply Delete  Mark Read Mark Unread Send/Receive GWM-ARES (9m)
Drafts Sender 4 Recipient 4 Subject 1 Type 4 Date~
Inbox I
Cutbox
Saved Messages
Sent
Trazh
My Status
Cnline
Online (D-RATS)
! WB4QDX
h

To send a regular message to another station, click New and either Memo or Email. Type in the
Destination callsign . Remember, this can either be the actual callsign or a tactical callsign. To ensure
the correct destination, ping all stations as in Chat and use the station name exactly as it appears. If the
desired station is not online, you must still use the exact destination callsign, but the message will not
leave your Outbox until the stations is online.

Type a subject and your desired message and click Send. After a short delay, you message will begin to
send as seen on the staus line at the very bottom of the main screen.



@’ Email Message

= @

Save Send Sendwia  Print

=l Routing Information

Source Callsign | WB4QDX
Destination Callsign | KF4PWI-1

Email Message

Subject |Message from EOC

Attachments
Path

Message
indditional cots needed for 25 new arrivals. Send as soon as possible.

E—

To send a form such as an ICS-213, select New and
the desired form from the list. A standard I1CS-213
form is included with D-RATS. Fill in the
information and select Send. Only the contents of
the form will be transmitted for efficiency and the
form will be populated on the receiving end.

The receiving station can click Print to view the
form as it actually appears for delivery to the
recipient.

(@ 1cs-213 Form =)
=T »

i Sawe = Send Sendvia Print

ICS-213 Form

=l Routing Information
Source Callsign | WB4QDX

Destination Callsign

Incident Name |

Time 16 2 27

Date Jan |>|16 [=]2013 [~]

To |
IC5 Position

m

Sender
ICS Position |
Subject |

Message

Attachments
Path

To open messages or forms received, click on Inbox and click on the desired message to open.



Our final Quick Start function is File Transfer. Click on Files to begin. The left hal of the screen shows any
files on your local computer in the folder you defined in the initial configuration for file transfers. Files
that are transferred to your station from a distant station will be stored there as well. A station must be
online to send or receive files.

To upload a file to a distant station, first connect to that station. If there callsign/name shows on the
right side of the screen under Stations, you may select them in the Staion drop down box and click
Connect. The station will show connected on the status line at the bottom of the screen when
connected. If there are files in the remote station’s folder, you will see a list of files on the right half of
the screen. Select the file you wish to upload to the distant station, by highlighting it on the left side
and click Upload. The file transfer will begin and progress will be shown on the status line at the

bottom.
§¢ D-RATS: WB4QDX - - [ ——
File View Help
Files Event Log Stations (3)
o @ 3 S | GWN-ARES (4m)
Connect  Disconnect Download Delete | MN3TSZ-W (4m)
Filename + Size {1 Date 4 Station: IZI Gwinnett ARES IZI WB4 QDX (7m)
|=| Apollo tonewav 44 KB 20:48:21 2010-04-24
|=| ARES Test_fldig3.bet 29KB  07:31:58 2010-06-02
|| ARES_Test_fldigil txt 4018 07:33:33 2010-06-02
|=| ARES_Test_fldigil.tet.wrap 461 B 07:29:38 2010-06-02
|| ARES_Test_fldigi2.txt 19KE  12:54:43 2010-06-12
|=| ARES_Test_fldigi5.csv 72KB  12:52:12 2010-06-12
|| D-RATS diagram 7.JPG 356 KB 19:51:052011-09-29

| D-RATS with analog radios.pdf 450 KB 19:52:34 2011-09-29
| D-RATS_and_packet_radic_0.3.3.pdf 93.5KE 19:55:12 2011-09-29

|~ examples.desktop 167 B 21:27:30 2010-03-16
|| Georgia Airport Codes.txt 11.0KE  20:45:52 2010-08-30
|| GW ARES check in.txt 32B 20:54:06 2011-01-31
|| IC91_20100510_WB4QDX.icf 109.8 KB 07:17:36 2010-05-13
|~ MNameFilebd 12KE  20:40:22 2010-04-24
=] skywarnxml 28KB  22:10:51 2012-12-26
|| Test Filetst 11KE  21:28:00 2010-03-238
|=| Trek chirp 11.wav 43KB  20:45:09 2010-08-30

My Status
Online

Online (D-RATS)
WEB4QDX

To download a file from a distant station, again make sure you are connected to that station. Click on
the file on the right side of the screen hightlightin the file and click Download. Again, the file tansfer
progress will be show at the bottom of the screen, Be sure to Disconnect from the distant station when
you are are finished tansfering files.



The Event Log tab provides a convenient log of all activities and provides a date and timestamp for each
activity.

These are the basic functions of D-RATS. There are other functions and features that can be used. For a
complete description of these features and their functions, you may view D-RATS Documentation at the
website at http://www.d-rats.com/documentation/.



http://www.d-rats.com/documentation/

